February 7, 2010

morris was a hero to most but he never meant shit to me

magnetos .. my POS just wont have it... spent a ridiculous amount of time trying to make both these things work. They did when they felt like it. Had the morris working well yesterday, well meaning when I finally got it started the bike ran great.. then the thing wouldn't start today at all.. just a few puffs.. redid the timing three times to make sure it was dead on, gaped the plugs, the points, cleaned the plugs a million times.. in the end all I got is a sore leg. I don't want to go back to a battery, distributor, coil setup but this shit aint moto if it wont start.

10 comments:

matt@machine said...

t...every mag i ever bought 2nd hand i just sent straight to get rebuilt.....motherfarking things....then they never let me down...

t said...

the Morris looks perfect, super clean.. points are nice.. has a good spark when you spin it. but what do I know I'm just a simple farmer. I followed your instructions Dave..but to no avail shit still wont work reliably or at all.

Jay said...

ehh... was kinda rainy today anyway

djp210 said...

Shit, that sucks man. I would get it started and hit it with the timing light. Did you try advancing and retarding it way out and trying it on each end of the spectrum?

Dave

t said...

Yeah I did try that.. I kept get it puffing back through the carb consistently so i thought it was preignition.. retarded it a little more but then got nothing. I think it's the Linkert more than anything..

Neil said...

Using a cork gasket right? Paper ones sometimes let in just enough moisture to ruin your day. A tip from Hunt magnetos I received ten years ago. Good luck, they are nice when they want to work.

Neil said...

Oh, and my buddy John is using the single fire adapter from Morris with great results.

t said...

Neil.. yeah it has a nice cork gasket. There is a little crack on the cap. Maybe that's part of the problem, at least from yesterday. I'm going to send it off to Morris and have them check it out. If it still doesn't work then I guess I'll have to go back to a battery setup.

I'm totally jealous of people that are using mags with good results.

cro said...

funny!!! The beauty of the mag is this.. its either spark or fuel, that is it. It is as simple as it comes. If the spark is good, its either too much fuel, or not enough. If the spark isnt any good, you may need to swap cables, mag coil, condenser. Start with the simplest things first.

I run them on almost every bike I build, love them. Yes, if things aren't right, they are a bitch, but that tells you, things aren't right.

Dont let it beat you!

t said...

Thanks cro. I want it to work. I'll keep at it.